https://lakefs.io/ logo
#dev
Title
# dev
a

Ariel Shaqed (Scolnicov)

03/10/2023, 10:42 AM
Can anyone help with
checks-validator
failing on CI but not locally. This PR, branch
feature/5371-rbac-to-acl-upgrade
. Strange behaviour: Since yesterday I have regular CI failures in "Run Linters and Checkers", part of the "Test" action.
make checks-validator
fails on GH (example) but succeeds locally ("it works on my machine"). Each time GH complains that some file is not updated. Some debugging runs yesterday showed that the recent
saml_auth
change to swagger.yml was missing. Things I've tried: • Compare digest of my branch to origin. Equal. • Re-run
make gen
, re-run
make checks-validator
. Still happens on GH. • Re-pull the openapi-generator image on my machine (in case a new image was re-tagged). No changes. Yesterday I ignored it and eventually it "went away" after rebase. Not sure this hoping this happens again is a strategy. Any clues?
b

Barak Amar

03/10/2023, 10:45 AM
Regenerate the CLI documents
Do you see any diff there?
Very strange as make gen should have regenerate these docs.
a

Ariel Shaqed (Scolnicov)

03/12/2023, 8:11 AM
I did it, seems to have worked. THANKS! Really sure I have
make gen
in my history, and also
make checks-validator
was happy. So all good now, but I suspect some weird dependency exists. Or I could just be confused about the whole thing. IF anyone else finds similar failures, please let me know and I will continue to investigate.
lakefs 1
2 Views