Tried to load a lakefs using the helm file and I g...
# help
Tried to load a lakefs using the helm file and I get the following message from the pod. I created a values.yaml, does anyone have any pointers to what I am missing?
Copy code
time="2023-07-10T14:22:21Z" level=info msg="Configuration file" func=<|> file="/build/cmd/lakefs/cmd/root.go:80" fields.file=/etc/lakefs/config.yaml file="/build/cmd/lakefs/cmd/root.go:80" phase=startup
time="2023-07-10T14:22:21Z" level=fatal msg="Failed to find a config file" func=<|> file="/build/cmd/lakefs/cmd/root.go:101" error="While parsing config: yaml: line 12: could not find expected ':'" fields.file=/etc/lakefs/config.yaml file="/build/cmd/lakefs/cmd/root.go:101" phase=startup
naked helmchart works so must be something in my values file.
Worked when I removed the disable stats false and gateway definition, must have been a parse error of the file.
Hi! The config file is invalid YAML the code is unable to parse it. This is where you define it and then it get’s deployed as a ConfigMap -> mounted as a file to the pod -> finally lakefs uses this file as argument on start So it seems that when lakeFS starts, it’s reading that file and failing to parse it. I would look into that file at the configmap level or even the mout inside the pod itself (i.e
cat /etc/lakefs/config.yaml
) and inspect that YAML structure / values.
Cool, will tinker a bit to see why my yaml is invalid because validator confirmed it as okay.
Good luck 🤞
👍 1